OOO: Possible fix for the command timed out error on Leopard

UPDATE:Thanks to Eric Bachard, a fix very similar to this will be appearing in OpenOffice.org 2.4.2 due to be released at the end of October 2008.

With a change in the way that X11 works on Leopard, the X11 version of OpenOffice.org has been giving an error message on startup saying “command timed out”. With previous versions of Mac OS X, OpenOffice.org had to make sure that X11 was running first be trying to start OpenOffice.org.

The following change should work for 2.4, 2.3.1, 2.3, and possibly earlier versions. Open the file OpenOffice.org 2.4.app/Contents/Resources/Scripts/main.scpt in “Script Editor”. (You will need to control+click the application icon and choose “Show Package Contents”.)
Then replace the code block “on openSoffice(aFile)“….”end openSoffice” with the following:
on openSoffice(aFile)
 if (atLeastOSXVersion(10, 5, 0)) then  
-- if we have leopard, we don't need to manually start the X server first
  set theCmd to "sh " & (quoted form of (POSIX path of getOOProgramPath() & "soffice")) & " "
  do shell script theCmd & aFile & shellTerminator()
 else
  set theDisplay to startXServer()
  if (theDisplay is equal to "error") then
   return
  end if
  set theEnv to "DISPLAY=" & theDisplay & " ; export DISPLAY; "
  set theCmd to "sh " & (quoted form of (POSIX path of getOOProgramPath() & "soffice")) & " "
  do shell script theEnv & theCmd & aFile & shellTerminator()
  -- logEvent("open CMD: " & theEnv & theCmd & aFile)
 end if
end openSoffice

Please comment on how this works for you.

82 thoughts on “OOO: Possible fix for the command timed out error on Leopard

  1. maveric

    Problem solved. Thank you Shaun. Would be nice if we can get it out with a possible 2.4.1.

    Plus we should make it public and post it in forums and on (trouble shooting) websites plus our own homepage.

    Reply
  2. Allen & Liz

    Yep, this worked fine. Still don’t like the way OOo depends on X11 & doesn’t run stand alone.

    Reply
  3. Anonymous

    Hmm the message went away but now OO won’t start. It appears to. X11 starts. then OO seems to close without anything happening.

    Reply
  4. Shaun McDonald

    Can you start OpenOffice.org by running /Applications/OpenOffice.org\ 2.4.app/Contents/MacOS/soffice in the xterm or terminal?

    If not try to remove the application preference and see if that works.

    Reply
  5. Anonymous

    Script works great. Thanks very much for fixing this annoying problem. I’m running OO 2.3.1 with OS X 10.5.2.

    Reply
  6. Anonymous

    Genius! Worked like a charm on 10.5.2 w/Ooo 2.4.0 intel. Also using X11 2201 update (XQuartz project) Thanks SO much!

    Reply
  7. Anonymous

    This is great. Thanks. Being new to Mac it took me a while to figure just how to do it and that only root could edit the script file but I got there in the end and OpenOffice starts up soooooo much faster now.

    Reply
  8. Anonymous

    Sweet, thanks. I have owned a mac for only a few weeks and this is all new to me. Still was easy to follow and make the changes!

    So much better now!

    Reply
  9. Anonymous

    I tried everything: go back to X11 1.1.2 on my Leopard or move forward to X11 2.2.1, then found this hint. Now it works.

    Reply
  10. NN

    It worked perfectly on our MacBook running OS X 10.5.2 and OOO 2.4
    It also fixed a problem we had on Logging Out from OOO (we had to Force-Quit the process).

    Thanks a lot.

    Reply
  11. Anonymous

    Works like a charm. It even seems like OO is starting much quicker than before.
    OSX 10.5.2
    OOO 2.4

    Reply
  12. Anonymous

    Could anyone please tell me where to find the file to edit? Also, why can’t I find anything called “script editor” or similar in my applications or utilities folder?

    Thanks a lot.

    Jesse

    Reply
  13. Anonymous

    Finally found the script editor and the file to edit — openOffice 2.4 opens smoothly now, thanks Shaun!

    Reply
  14. Anonymous

    Yes, thank you, it worked for me. Too bad I had to spend 30 minutes searching for your fix, rather than have them implement this themselves.

    Reply
  15. NS

    Very smooth, thanks. OS 10.5.3 with Xquartz 2.2.1. Looking forward to looking at the aqua you pointed out.

    Reply
  16. Woody UK

    Did NOT work, I still get the error “Command Timed Out” and then OO just hangs.
    I’ve read and tried all the work-arounds and none of them work including this one.
    I was running OO2.2 on Tiger and it worked fine. I’ve upgraded to Leopard 10.5.3 and neither OO2.2 nor 2.4 will work on it!
    I’ve got a Quad G5 PPC with 16GB Ram & 1TB & 250GB hard drives so there is no issues with performance.
    Before I changed the file as you suggested I tried opening X11 1st, even that didn’t work. I didn’t even need to as when I try to start OO it always opened X11 even before I changed this text.
    The only thing I can think of is when I installed Leopard, I copied all my Apps and their folders including Utilities folder with X11 in it, so is it a different version of X11 on Tiger than it is on Leopard and if yes, then I reckon I could have corrupted it.
    Anyone know where I can d/l X11 for Leopard from?
    I’m glad to hear this fix worked for some of you

    Reply
  17. Shaun McDonald

    Woody UK:

    I have X11.app 2.2.0.1 – (xorg-server 1.3.0-apple5) on Leopard. (See About X11 in the X11 menu.) I’m using Mac OS X 10.5.3.

    It appears that you have corrupted X11 after installing Leopard by copying all your apps over. I think you can do a custom install of Mac OS X Leopard with just installing X11. Then install the Mac OS X 10.5.3 Combo update.

    I’d be surprised if you hadn’t corrupted any of your other Mac apps like Safari and Mail.

    Reply

Leave a Reply to ptamaro Cancel reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.